Wednesday, August 19, 2009

Other SB-220 Repairs and Modifications...

Replacing the Zener, ZD1:

As I mentioned in my previous post, my SB-220 also had a blown zener diode (ZD1) and two smoked resistors: the 1 ohm power resistor (R1), and the 0.82 ohm power resistor (R3).

(BBQ, anyone?)

Luckily, I have a well-stocked junk box and I quickly found a substitute 1 ohm power resistor. To create the 0.82 ohm power resistor I paralleled two "junk box" 1.6 ohm power resistors. (the resultant 0.8 ohms is within 2.5% of the original 0.82 ohms -- close enough!)

The zener was a different problem. The SB-220's part's list called out a 1N3996A zener (5.1V, 10W). Well, the closest I had in the junk box was a 1N3995A (4.7V). But I thought I could do better than this.

A number of other posts on the Internet mention using series-connected rectifier diodes to achieve the appropriate voltage drop. Typically, they'd show 7 or 8 diodes in series, which, if forward biased, will put the voltage somewhere in the 4.9 - 5.6 volt range, depending upon the number of diodes and their characteristics (forward voltage drop is usually in the range of 0.7 to 0.8 v per diode).

An advantage to using diodes, too, is that it allows the bias voltage to be "tweaked" in steps of around 0.7 volts, thus allowing one to get close to the preferred no-signal plate current. (Per Heathkit (ref. Bulletin SB-220-1 @ SB-220 Service Bulletins), no-signal plate current (in CW/Tune mode) should be between 90 and 120 mA, and per Rich Measures' web site, the no-signal plate current in SSB mode should be between 160 and 200 mA for best linearity (lowest distortion)).

So I created a series-string of 8 diodes and connected them in place of ZD1. I used 1N4001 diodes, which are rated at 1 A. If one wants to be extra safe, use 3A diodes (such as those in the 1N5400 series), but I went with the 1 amp variety because I had a junk box full of them (and I believe that the SB-220 Rectifier Board replacement available from Harbach uses 1A diodes as their zener replacement, too).

(Click on image to enlarge)

Diode reverse-voltage rating is not that important because the diodes are not reverse-biased. And the 0.01 uF cap is just to keep RF out of the diode string.

I installed a board with 8 diodes and started testing the no-signal plate current. With 8 diodes, the Plate Current meter reads 80 mA no-signal plate current in CW/Tune mode, which is just a bit below the minimum that Heathkit recommends (90 mA). However, 6 diodes gives a plate current of 100 mA, and the no-signal current in SSB mode is 160 mA -- right at the lower end of what Rich Measures recommends. So I shorted-out two of the eight diodes to give me the final count of six.

(Click on image to enlarge.)
The 2 right-hand diodes have been shorted-out, leaving 6 diodes in series.
And just behind the board you can see the two resistors paralleled to make 0.8 ohms.

Replacing the Plate-Voltage Voltage Divider:

Another problem I discovered was that the three 4.7 Mohm, 2 Watt resistors (R6, R7, and R8) used to divide down the Plate Voltage (for the Plate Voltage meter) were all bad (one was open, one read 20 Mohms, and the third read 6 Mohms on my DVM). Per other reports on the web, failures such as this were due to the resistors being greatly overstressed (they're each subject to somewhere in the range of 750 to 1000 volts, and (allegedly) the original resistors were only rated at 350 working-volts dc). Unfortunately, didn't have any resistors with a high enough working voltage spec in my junkbox.

Instead, I decided to replace them with series-strings of lower-wattage resistors, which would allow me to divide the overall plate voltage (for this purpose assume 3 KV) amongst a greater number of resistors, so that each resistor sees a lower working-voltage.

I replaced each 4.7 M, 2 watt resistor with a string of four 1/4 watt resistors. For two of the three original resistors I used four 1.2M, 1/4 watt resistors for each 4.7 M resistor. For the third 4.7 M resistor I used three 1.2M, 1/4 watt and one 1M, 1/4 watt resistor. Total resistance is 14.2 Mohms, which is close enough to the original 14.1 Mohms.

(Click on image to enlarge)

The working-voltage rating of 1/4 watt carbon-film resistors can be either 250 VDC or 300 VDC. I don't know the manufacturer of my resistors, so I'm going to assume my resistors are 250 VDC. If we assume a 3KV max plate voltage, will we be within the working-voltage specification of these resistors?

Doing the math, given 3 KV across the entire string, then each of the eleven 1.2M ohm resistors should have just a bit less than 250 VDC across it. The single 1M ohm resistor should have about 200 volts across it. So the working-voltage for the 1.2M resistors is right at the maximum, but, given that my PA voltage actually runs less than 3KV (even in SSB mode), we actually have a bit more margin.

Also -- in this application each resistor only dissipates about 62 mW, so it's OK to use 1/4 watt resistors. It's really their working-voltage rating that we care about.

(By the way, when installing the resistor strings, don't forget to keep them away from each other and away from other components or chassis parts that they might short to).

Protecting the Meters:

Here's a simple mod that should prevent another blown out meter (such as happened to me with my Plate-Voltage meter). I used two 1N4001 diodes per meter. The mod is this: at each meter connect the anode of one diode and the cathode of the other diode to one of the meter's terminals, then connecd the opposite leads of these two diodes to the meter's other terminal (the end result: two diodes in parallel across the meter's terminals, one diode is reversed from the other diode). Do this for each meter.

(A note: the meters will hit full-scale if the voltage across them is 280 mV or greater. Silicon diodes such as the 1N4001 can actually develop a forward voltage of more than 1 volt for currents in excess of 1A. This means that you could possibly have 700 uA (or a bit more) running through your meter's coil, instead of the 200 uA. I don't see this as being a problem (I think it very unlikely that the coil will burn out with 3.5x the full-scale current), but, if you're feeling insecure, you might want to look into using Schottky diodes in lieu of the 1N4001 diodes, or possibly a different solution.)

Adding a Keying circuit for Solid State Transceivers:

The amplifier keying jack has 120 volts across it, which can be deadly for solid-state transceivers. Here's a circuit I made (defined primarily by parts I had in my junk box). It's based upon a design by K8SS in the January, 1988 issue of QST but, because I didn't want to use the high-power, heat-dissipating resistor used in that original design, I instead modified it to be low-current (it uses a few extra parts -- but hey, they were already in my junk box).

(Click on Image to enlarge)

The relay in my SB-220 has a coil resistance of 4.6K ohms, which means that, when keyed on, about 30 mA will pass through it. An MPSA42 transistor has a minimum beta of 40 (at Ic = 30 mA), so to give myself a bit of base-drive margin (because I wanted to keep my currents low to minimize power dissipation) I simply hooked two together in a Darlington configuration. The 10K ohm resistors at the bases of these two MPSA42 transistors are simply there to dump any charge in their base regions when drive to them is removed.

The zener diode/MPSA42 circuit acts as a simple voltage regulator, and it provides just about 12 volts with minimal heat dissipation (because of the low-current operation). The 0.01 uF cap is just an RF bypass at the high-impedance node.

The 1N4148 adds some extra input protection, and the 1N4003 is actually across the relay coil, and snubs the voltage spike that occurs when the relay turns off.

Here's my implementation -- the parts are a bit jammed together simply because, when I started building it, I wasn't sure which of two pre-existing holes in the board I wanted to use for mounting it.



Other Notes:

1. Whenever removing the SB-220 from its cabinet, or when removing the top of the internal cage, be sure that the SB-220 is unplugged from the AC mains. Also, if the unit has been powered-up, first wait a LONG time (to allow the High-Voltage (HV) to decay down to safe levels) before removing the cover, otherwise you stand a good chance of blowing a component (such as the 0.82 ohms resistor) when the interlock shorts out the HV (been there, done that!).

2. The Internet has a wealth of information on modifying SB-220 Linear Amplifiers. Take a look around!

Caveat:

IMPORTANT NOTE: Use care whenever modifying equipment. Do not undertake these modifications if you are unsure as to how to implement them, or if you do not understand why these mods were implemented in the manner shown herein. Any time you modify your equipment, you do so at your own risk.

4 comments:

d2uavid said...

when i turn on my sb220 the relay engages and the two tubes start to turn red slowly.my recieve is gone until i turn the sb220 back off.then my recieve comes back and the relay disengages.what is causeing the sb220 to key itself up when i turn it on?

Jeff said...

Something is probably pulling the relay line low, such as a short or something else, and this is turning the relay on. You'll need to trouble-shoot it to find out what the problem is.

AMATEUR RADIO STATION : 9M2GET said...

HAI JEFF

AFTER I REPLACE THE RECTIFIER BOARD THERE WAS SOME ARCHING NEAR THE TUBE BUT NOT TO LONG. IS IT DANGEROUS. TQ

Jeff said...

Hi 9M2GET,

Your amplifier should not be arcing. I always consider arcing dangerous, and I strongly recommend it be examined by someone with experience in servicing amplifiers.

Best of luck!

- Jeff, k6jca